Reset Button Fails to Reset Network Configuration

참고

This issue is only present on Zivid 2.

../_images/factory-reset-button.png

Problem

전원 커넥터 아래의 리셋/재설정 버튼을 사용해도 카메라의 네트워크 구성이 기본 구성으로 초기화/재설정되지 않는 경우가 있습니다. 상태 LED에 재설정이 수행되었음을 나타내더라도 네트워크 설정이 재설정 후에도 동일하게 유지됩니다.

Cause

이 방식으로 네트워크 설정을 재설정하는 것은 재설정 버튼을 누르고 있을 때 실행되는 별도의 펌웨어 구성 요소에 의해 처리됩니다. 카메라의 네트워크 설정을 확인할 수 없는 것은 이 구성 요소의 알려진 문제입니다. 따라서 상태 LED가 재설정되었음을 나타내더라도 네트워크 설정은 동일하게 유지될 수 있습니다. 정상적으로 실행되는 펌웨어는 이에 영향을 받지 않으며 카메라는 네트워크 설정을 위한 정상적인 절차를 통해 항상 복구할 수 있습니다.

Solution

Known network configuration

카메라의 네트워크 설정을 알고 있고 기본 구성으로 재설정하려는 ZividNetworkCameraConfigurator CLI 도구를 사용할 수 있습니다.

  1. 다음을 통해 카메라에 연결된 상태에서 터미널에서 ZividNetworkCameraConfigurator get-config 도구를 실행하여 카메라에 도달할 수 있는지 확인합니다.

    ZividNetworkCameraConfigurator get-config <host>
    

    여기서 <host> 는 카메라의 IP 주소입니다. 카메라에 접속할 수 없는 경우, PC 네트워크 인터페이스가 카메라와 동일한 모드, 서브넷 및 IP 범위(단, IP는 다름)로 구성되어 있는지 확인하세요(Network Configuration 참조).

  2. ZividNetworkCameraConfigurator set-config 도구를 사용하여 카메라 네트워크 설정을 재설정하십시오.

    ZividNetworkCameraConfigurator set-config <host> --static --ip <ip> --subnet-mask <mask> --gateway <gateway>
    

    여기서 <host> 는 카메라의 현재 IP이고 <ip> 는 변경하길 원하는 카메라 IP입니다. <mask> 는 서브넷 마스크이고 <gateway> 는 게이트웨이입니다. 카메라의 기본 설정은 IP는 172.28.60.5, 서브넷 마스크는 255.255.255.0, 게이트웨이는 172.28.60.1 입니다.

Unknown network configuration

SDK 2.11로 업그레이드하고 CLI 도구 ZividListCameras 를 실행하여 네트워크 구성을 찾으세요.

SDK 2.11부터 Zivid SDK는 네트워크에 있는 모든 Zivid 카메라를 감지하고 상태를 보고합니다. SDK 2.11로 업그레이드할 수 없는 경우 네트워크 분석기를 사용하여 IP 주소를 찾을 수 있습니다. 다음 단계에서는 Wireshark 를 예로 들어 설명합니다.

  1. 카메라를 PC에 연결합니다.

  2. Wireshark 열고 카메라에 연결된 네트워크 인터페이스를 선택합니다. (예: 이 예에서는 Ethernet 3)

  3. 정보 세그먼트에서 카메라의 IP 주소를 알리는 ZividAS 의 ARP 알림이 표시될 때까지 기다리십시오. 아래 예에서 IP는 Wireshark 에서 172.28.60.5 로 표시됩니다.

이제 카메라의 IP 주소를 알고 있으므로 Known network configuration 의 단계를 따를 수 있습니다.

그래도 카메라 네트워크 설정을 재설정할 수 없으면 customersuccess@zivid.com 에 문의하십시오.