Reset Button Fails to Reset Network Configuration

Note

This issue is only present on Zivid 2, not Zivid 2+.

../_images/factory-reset-button.png

Problem

Using the reset button below the power connector will sometimes not reset the camera’s network configuration back to the default configuration. The network configuration remains the same after a reset, even though the status LED indicates that a reset has taken place.

Cause

Resetting the network configuration this way is handled by a separate firmware component that runs when the reset button is held. It is a known problem in this component that it may be unable to see the camera’s network configuration. Thus, the network configuration may remain the same, even though the status LED indicates that a reset has taken place. The normally running firmware is unaffected by this, and the camera is always recoverable by the normal procedure for network configuration.

Solution

Known network configuration

If you know the network configuration of the camera and wish to reset it to the default configuration, you can use the ZividNetworkCameraConfigurator CLI tool.

  1. Verify that you can reach the camera by running ZividNetworkCameraConfigurator get-config tool in a terminal while connected to the camera by

    ZividNetworkCameraConfigurator get-config <host>
    

    where <host> is the IP of the camera. If you are unable to reach the camera, make sure your PC network interface is configured to the same mode, subnet and IP range (but different IP) as the camera (see Network Configuration).

  2. Reset the camera network configuration with the ZividNetworkCameraConfigurator set-config tool by

    ZividNetworkCameraConfigurator set-config <host> --static --ip <ip> --subnet-mask <mask> --gateway <gateway>
    

    where <host> is the current IP of the camera, <ip> is the desired IP of the camera, <mask> is the subnet-mask and <gateway> is the gateway IP. The default configuration is IP 172.28.60.5, subnet-mask 255.255.255.0 and gateway 172.28.60.1.

Unknown network configuration

Upgrade to SDK 2.11 and run the CLI tool ZividListCameras to find the network configuration.

From SDK 2.11, the Zivid SDK detects all Zivid cameras on the network and reports their status. If you are unable to upgrade to SDK 2.11, you can use a network analyzer to find the IP address. The following steps uses Wireshark as an example.

  1. Connect the camera to your PC.

  2. Open Wireshark and select the network interface connected to the camera, e.g. Ethernet 3 in this example.

    ../_images/wireshark-network-interface.png
  3. Wait until you see the ARP announcement from ZividAS, which announces the IP address of the camera in the info segment. In the example below, the IP is seen from Wireshark to be 172.28.60.5.

    ../_images/wireshark-camera-ip.png

You now know the IP address of the camera and can follow the steps in Known network configuration.

If you are still not able to reset the camera network configuration, contact customersuccess@zivid.com.